FYI: The application on the left requires IE 4.0 or later to work properly. Netscape 6.1 will NOT process it.